搜索

跨交换机实现VLAN间通信


发布时间: 2022-11-24 20:37:01    浏览次数:34 次

 

在没有完成划分VLAN之前,各PC之间都能互通(属于默认VLAN1)。

 

2.创建VLAN,配置Access接口

 #在S1上创建VLAN10 VLAN20
[S1]vlan 10
[S1-vlan10]quit
[S1]vlan 20
[S1-vlan20]quit

 #在S2上创建VLAN10 VLAN20

[S2]vlan 10
[S2-vlan10]quit
[S2]vlan 20
[S2-vlan20]quit

 #在S3上创建VLAN10 VLAN20

[s3]vlan 10
[s3-vlan10]quit
[s3]vlan 20
[s3-vlan20]quit

配置完成后,使用display vlan 命令查看所配置的VLAN信息,以S1为例

 

3、在S1上配置Ethernet 0/0/2和Ethernet0/0/3为Access接口,并划分相应的VLAN。

[s1]interface Ethernet 0/0/2
[s1-Ethernet0/0/2]port link-type access
[s1-Ethernet0/0/2]port default vlan 10
[s1-Ethernet0/0/2]quit
[s1]interface Ethernet 0/0/3
[s1-Ethernet0/0/3]port link-type access
[s1-Ethernet0/0/3]port default vlan 20

 

 在S2上配置Ethernet 0/0/3和Ethernet0/0/4为Access接口,并划分相应的VLAN。

[s2]interface Ethernet 0/0/3
[s2-Ethernet0/0/3]port link-type access	
[s2-Ethernet0/0/3]port default vlan 10
[s2-Ethernet0/0/3]quit
[s2]interface Ethernet 0/0/4
[s2-Ethernet0/0/4]port link-type access
[s2-Ethernet0/0/4]port default vlan 20

3、配置Trunk接口

将PC1所连入的交换机接口划入到相应的VLAN后,测试相同VLAN中的PC是否能够通信。

测试PC1与PC3之间的连通性:

 

 测试PC2和PC4之间的连通性:

 

此时同VLAN的PC间不能通信,虽然与PC端相连的交换机接口上创建并划分了VLAN信息,但是在交换机与交换机之间相连的接口上并没有相应的VLAN信息,不能识别和发送跨越交换机的VLAN报文,此时VLAN只具有在每台交换机上的本地意义,但无法实现相同VLAN的跨交换机通信。

为了让交换机间能够识别和发送跨越交换机的VLAN报文,需要将交换机间的接口配置为Trunk接口,配置时要明确被允许通过的VLAN,实现对VLAN流量传输的控制。

在S1上配置Ethernet0/0/1为Trunk接口,并允许VLAN 10和VLAN 20通过。

[s1]interface Ethernet 0/0/1	
[s1-Ethernet0/0/1]port link-type trunk
[s1-Ethernet0/0/1]port trunk allow-pass vlan 10 20

在S2上配置Ethernet0/0/2为Trunk接口,并允许VLAN 10和VLAN 20通过。  

[s2]interface Ethernet 0/0/2
[s2-Ethernet0/0/2]port link-type trunk
[s2-Ethernet0/0/2]port trunk allow-pass vlan 10 20 

在S3上配置GE0/0/1和GE0/0/2口为Trunk口,并允许所有VLAN通过。

[s3]interface GigabitEthernet 0/0/1	
[s3-GigabitEthernet0/0/1]port link-type trunk
[s3-GigabitEthernet0/0/1]port trunk allow-pass vlan all
[s3-GigabitEthernet0/0/1]quit
[s3]interface GigabitEthernet 0/0/2
[s3-GigabitEthernet0/0/2]port link-type trunk
[s3-GigabitEthernet0/0/2]port trunk allow-pass vlan all

配置完成后,使用display port vlan 检查Trunk配置情况,以S3为例。

 

此时,S3的GE 0/0/1和GE 0/0/2已成功配置为Trunk接口,并且允许所有VLAN流量通过(VLAN 1~4094)。

再次验证不同交换机上的相同部门的PC间连通性。

测试PC1与PC3之间的连通性:

 

免责声明 跨交换机实现VLAN间通信,资源类别:文本, 浏览次数:34 次, 文件大小:-- , 由本站蜘蛛搜索收录2022-11-24 08:37:01。此页面由程序自动采集,只作交流和学习使用,本站不储存任何资源文件,如有侵权内容请联系我们举报删除, 感谢您对本站的支持。 原文链接:https://www.cnblogs.com/longlyseul/p/16923189.html